Kein Dauerlogin

      Moinsen.
      Da hatta Hans Recht, ist bei mir auch so.
      Cookies lösche ich automatisch, besonders dieralten, es gibt also bei mir keine Altcookies, nur sitzungsaktuelle.
      Noch absurder wird es, wenn das Forum meine Aktionen - ob im Profil oder im Texteditor - abweist mit dem Rüffel "...nicht angemeldet"[auf rosa Grund], ein weiterer geöffneter Tabulator auf dem das forum läuft aber auf grünem Grund meldet, das der User aktiv angemeldet ist. Ein Ausloggen dann wieder ein " Abmelden fehlgeschlagen, Sitzung abgelaufen" auf rosa Grund bekannt gibt, aber ein neuer Tab im Forum wieder in Grün meine noch laufende Sitzung bekannt gibt.
      /Die Meldungstexte sind grob aus dem Kopf erinnert, da nach einem Klick gleich weider verschwunden, also nicht zu wörtlich nehmen.

      Weiters funktioniert die vollautomatische Anmeldung aus einem führenden, allbekannten und sicher auch von dieser (Marktführer-)Software unterstützten Paßwortmanager jetzt nicht mehr.
      Diese füllt für gewöhnlich auf bloßen Klick auf einen Button von selber die benötigten Daten Username/Paß in die richtigen Felder der Formulare. Das klappt eigentlich bei jedem Forum, jedem Webdienst, jeder noch so knuffeligen Seite mit Anmeldungsmöglichkeit.
      Nur hier klappt es nach der Umstellung nun nicht mehr.

      //
      Btw. mußte ich diesen Text dreimal schreiben, so oft wurde ich beim Schreiben vom Forum abgeworfen, aber lief es dennoch in einem weiteren Tab weiter und führte mich als angemeldet, sprich ich mußte mich nicht neu anmelden aber über den jewewils offenen Tab wieder die richtige Antwortstelle ansteuern. Text war natürlich immer mit weg.
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Neu hinzu gekommen - kein Link im Forum führt auf Anhieb weiter, es erscheint lediglich eine weiße Seite.
      Nach mehrfachem Aktualisieren oder neu aus dem Index laden erscheint irgendwann der gewünschte Inhalt.
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Klar, hab ich.
      Jeder Link heißt jeder Link, also bspw. der Klick auf
      "Antworten", "Absenden", "ungelesene Beiträge", ""Profil bearbeiten"
      usw. usf.
      Wenn ich eine Prognose abgeben sollte, würde ich davon
      ausgehen das der Parser die Linkanweisung nicht zeitnah genug abarbeitet
      und CSS nicht lädt, sondern den reinen unformatierten Text.

      Heute
      ist das Problem bisher noch nicht aufgetreten, die gesamte Ladezeit ist
      aber auch wesentlich kürzer als noch gesterndas Tool um einen
      Screenshot davon anzufertigen wartet aber schon im Hintergrund darauf.
      Das Nicht_Eingeloggt_Problem ist aber unverändert zu gestern.

      Die durchaus nicht immer gleichen Alert-Boxen, die beim Beiträge absenden generiert werden zeigt das Anhangbild auszugsweise
      Bilder
      • Zwischenablage01.jpg

        52,8 kB, 1.342×686, 17 mal angesehen
      • Zwischenablage02.jpg

        49,51 kB, 1.428×478, 15 mal angesehen
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Hallo allerseits,

      ich weiß ja nicht, wie inwieweit die Softwareumstellung schon abgeschlossen, oder noch im Gange ist. Mir fällt nur auf, dass ich in den Threads, wie etwa hier

      Grundig SV140 Verstärker SV200

      die Bilder von Hans sehe, bei meinen eigenen aber, wenn ich eingeloggt bin, kein Bild, keinen Link, nur eine freie Fläche sehe, wenn ich nicht eingeloggt bin, ist zwar ein Link vorhanden, beim Klick darauf erscheint allerdings kein Bild, nur eine schwarze Fläche.
      Achim
      Stand heute und hier:

      + CSS wird jetzt immer geladen.

      -
      Login weiterhin keine Paßwortmanager-Autoanmeldung möglich, anhand des
      unten beschriebenen Verhaltens fast ständig nötigen Neu-Einloggens ist
      sinnvolle Nutzung fast unmöglich, es sei denn man hat Spaß daran
      ellenlange 128Bit-sichere ASCII-Codes in Abfolgen von wenigen Minuten
      permanent von Hand neu einzutippen.

      - Weiter kein eingeloggt
      bleiben - weiter wird aber angezeigt online/eingeloggt aber beim
      Absenden von Beiträgen nichts angenommen, da Meldung: Nicht eingeloggt.

      -
      Weiter kein korrektes Ausloggen möglich, Sitzungen bleiben also eine
      unbekannte Zeitlang offen (Sicherheitsproblem) da trotz aller
      Online/Eingeloggt Anzeigen des Forums es dennoch meint ich wäre nicht
      eingeloggt.

      - Weiter sind Sitzungen immerzu direkt nach Start schon wieder beendet.
      Heißt: Jede Aktion von Lesen über Schreiben bis Profilaktionen erfordert weiterhin direkte pausenlose Schrittfolge:
      Browser-Neuladen,
      von Hand neu Einloggen (da Automanager im Anmeldeforumlar nicht mehr
      funktioniert), direkt und ohne genug Zeit irgendetwas zu schreiben
      Absenden eines irgendwo (Zwischenablage natürlich nicht da wegen dem
      ausgeloggt werden ständig mit Logindaten gefüllt) von einem selbst
      zwischengepufferten Text wobei der Foreneditor die Formatierungen (Wie
      Zeilenumbruch, Zeilenlänge usw.) verliert, weshalb meine Texte aussehen
      wie hingesch....

      Nur mal so als Feedback/Zwischenstand.

      Ich mache dann erstmal eine kleine Pause, Nutzung ist für mich so zu nervig. ich lese erstmal im Wesentlichen nur mit.
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Jogi, kann ich nicht nachvollziehen.

      Bei mir funktioniert der neue Keks ohne Probleme.
      Wie es der Zufall so wollte, schmiert mir gerade die Festplatte ab.
      Nach einem Update startete der Firefox nicht mehr.
      Momentan habe ich ein Linux über USB-Stöpsel gebootet, fast jungfräulich.
      Login war nur einmal nötig, geht jetzt auch am nächsten Tag automatisch.
      Ich habe natürlich ein Häkchen gesetzt, immer eingeloggt zu bleiben.
      Beim anderen Rechner mit zusätzlichem alten Keks war am nächsten Tag erneutes Einloggen nötig.

      Mit den Editor-Fenstern kann ich nicht nachvollziehen.
      Beide habe ich ausprobiert, den einfachen und den "Erweiterte Antwort".
      In beiden Editoren sehe ich meinen Text und auch das Absenden geht problemlos.
      Anschließend sehe ich meinen frisch erstellten Beitrag.

      Andreas
      Was bedeutet DL2JAS? Amateurfunk, www.dl2jas.com
      Lieber Jogi!

      Angehängt ein Bildschirmphoto, wie der Editor aussieht.
      Man sieht den, mit dem auch das Hochladen von Bildern geht.
      Der erste Editor sieht fast gleich aus, nur halt nicht die erweiterten Funktionen.
      Je nach Betriebssystem und Browser ist das Erscheinungsbild etwas anders.
      Das als Hilfe für Dich, nur bei Dir scheint es die Probleme zu geben.

      Andreas
      Bilder
      • editor-saba.png

        71,18 kB, 940×647, 10 mal angesehen
      Was bedeutet DL2JAS? Amateurfunk, www.dl2jas.com
      Hallo lieber Andreas,

      bei mir sieht der Editor nicht anders aus, das Problem mit dem Stylesheet was es vorher gab ist ja verschwunden.

      Der Editor funktioniert wohl jetzt auch genauso wie üblich, das Problem ist das bei Klick auf Absenden alles Geschrieben wieder weg ist, weil ich aus unerfindlichem Grund nicht eingeloggt bleibe. (Haken im Login ist wie man im Bild sieht gesetzt)

      Das Problem des Einloggens gestaltet sich bei mir wie auf dem Bild zu sehen, Zustand nach Auto-Login des PW-Managers "KeePass":



      Das Paßwort wird also nicht eingetragen und somit auch nicht eingeloggt.

      /
      KeePass ist eine Standard-Software die seit Jahr und Tag einwandfrei arbeitet und die auch von allen aktuellen und bekannten Forenscripten unterstützt wird. Nix Exotisches also. Was mir problemlose Logins auf allen für mich interessanten Seiten und auch im alten Forum bestätigen.
      /

      Vielleicht hilft es zu betonen das das Ganze Problempaket mit aktuellen Versionen von Windows auf mehreren unterschiedlich konfigurierten PC und Notebooks auftritt, das es den Browser Firefox (aktuell) betrifft, das es das Problem in keinem anderen Forum oder Webseite die ich besuche gibt. Unter Opera gelten andere Laufzeiten bis zum ungewollten Logout, aber im Prinzip ist es das gleiche Verhalten, auch das Verhalten das das PW nicht automatisch angenommen wird.

      Da ich außerdem auch noch mehrere Internetwege ausprobiert habe kann es nach Menschenermessen als serverseitig angesehen werden.

      Der Verkehr hier zeigt ja auch eine noch größere Ruhe als sonst schon, vielleicht kommen die anderen alle nicht richtig herein.

      VieI Glück beim Problemfinden
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Lieber Dietmar!

      Eine Abmeldung nach längerer Zeitdauer dürfte normal sein.
      Das ist ein Sicherheitsmechanismus, daß irgendwann ein Logout erfolgt.
      Bei der alten Software war das ein Problem, wenn man sehr lange Beiträge verfasste.
      Die Zeit habe ich damals hochgesetzt.
      Hier muss ich mal gucken, wo man das einstellen kann.

      Andreas
      Was bedeutet DL2JAS? Amateurfunk, www.dl2jas.com
      Lieber Jogi!

      Ich habe mal etwas nachgedacht.
      Gleiches Problem scheint es bei anderen Mitgliedern nicht zu geben.
      Als Admin wird man ganz schnell angeschrieben, wenn was nicht läuft.
      Bis jetzt seit Umstellung kam noch keine einzige E-Mail in der Richtung.

      Für mich ist es schwierig, die Konstellation auszuprobieren, da ich kein Win habe.
      Stimmt nicht ganz, ein altes XP hätte ich, jedenfalls kein halbwegs aktuelles Win.
      Am Server sollte es nicht liegen, das Forum läuft über SULEITEC.
      Nicht sehr bekannt, kleinerer qualitativ hochwertiger Anbieter zu günstigem Preis.
      Dort bin ich seit vielen Jahren, also auch schon vor der Software-Umstellung.

      Möglicherweise mag der Passwortmanager tatsächlich nicht die Forensoftware.
      Mich stört etwas, daß Du da mehrere Fenster hast oder hattest.
      Hast Du gleichzeitig mehrere Sitzungen SABA-Forum offen?
      Bei mir mit Linux geht das aktuell und früher hatte ich auch keine Probleme.
      Möglicherweise ist da Win missmutig, mag so Spielchen nicht.
      Mach mal Forum nur auf einem Rechner und nur eine Sitzung.

      Andreas
      Was bedeutet DL2JAS? Amateurfunk, www.dl2jas.com
      Moin Andreas.

      Nee, das Tabbed Browsing ist eine Grundeigenschaft
      neuerer Browser, unter Windows das klappt solange problemlos bis der
      Windowsspeicher und der Auslagerungsspeicher randvoll sind und keine
      Tasks mehr frei sind. Das kann bei meinem Vierkern-PC mit genügend RAM
      und schier endlosem virtuellen Speicher locker bis 1000 Tabs gut gehen.
      Die
      inaktiven Tabs werden außerdem platzsparend schlafen gelegt
      (eingefroren), soll heißen das System tätigt alle Datenübertragungen
      selbständig um so einen Tab wieder aufzuwecken. Es wird also auch wieder
      in die laufende Forensitzung in passender Weise eingeloggt.

      Nichtsdesto
      weniger habe ich hier immer nur dieses Forum geöffnet, evt.
      auftauchende Zweit-Tabs sind Instanzen die das Forenscript selber
      erzeugt und öffnet und schließt wie es ihm beliebt.
      So bspw.
      das Anmeldeformular, das erscheint als Popup oder als Browserfenster
      oder als Tab, bei mir eben als Tab weil das sinnvoller ist als die
      anderen beiden Wege. Aber auch wenn ich diese durch Umkonfiguration des
      Browsers erzwinge ist das Verhalten kein anderes, es wird so oder so die
      Datenkonvention eingehalten den das Forum vorgibt.

      Ich komme mal deshalb direkt zu meinen aktuellen heutigen Erkenntnissen/Stand

      Kein Autologin:

      Der
      Grund ist mit tagelangem Herumwühlen in den BurningBoard Gegebenheiten,
      sowie Experimente mit der Clientkonfiguration wohl gefunden.

      Als
      verantwortlich hat sich der nicht standardkonforme, abweichende
      Anmelde-Formular-String der neuen Software erwiesen, der im alten Forum
      noch konform war zu dem was solche PW-Manager standardgemäß im
      PHP-Forular erwarten. Mit diesem Formular schießen alle PW-Manager die
      nach etwa dem gleichen Prinzip arbeiten das PW ins Leere, deshalb wird
      man nicht automatisch eingeloggt.

      Reparaturmöglichkeiten gibt es auf zwei Ebenen.
      - serverseitig - ...
      -
      clientseitig - Änderung (patchen) des User-Login-Strings eines jeden
      Benutzers bei sich in seinem PW-Manager, sofern dieser das zuläßt und
      der erfahrene Benutzer genau weiß was er tut, sonst schießt er sich
      möglicherweise den Login wahlweise den PW-Manager komplett ab.

      Fazit - für
      den Benutzer ohne die Kenntnis seinen PW-Manager zu einem gepatchten
      String zur Anmeldung zu senden ist mit dem aktuellen Login-Formular der
      Software der Auto-Login dahin.

      Sitzungsablaufproblem (kein dauerhaftes eingeloggt bleiben, nach kurzer Zeit ohne eigenes Zutun ausgeloggt werden)

      Die Sitzungen laufen jetzt heute aktuell länger, aber immer noch zu kurz.
      Alle weiteren angeführten Probleme sind nach meinen Recherchen Folgen des zu schnellen ausgeloggt werdens.

      Fazit - Clientseitig ist dem nicht direkt beizukommen.
      Als
      Benutzer kann man den Timeout nicht beeinflussen, evt. kann man mit
      einem Forcer (gibt es sowas eigentlich überhaupt noch?) benutzen oder
      seinen Browser dementsprechend einsetzen, aber das erzeugt hohe
      Serverlast und ist somit nicht die feine Art.
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Als Nachtrag noch ein Screenshot vom Schreiben des vorherigen Textes.

      Es zeigt deutlich das nach gerade erfolgte Login und der absichtlich deutlich formatierte Editortext samt dem Text "Online" am Avatar
      im gleichen Augenblick beim Klick auf "Absenden" als "nicht eingeloggt" moniert wird.
      Die Auswirkung auf den Text ist am Text selber erkennbar, alle Formatierungen sind weg.

      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
    • Benutzer online 1

      1 Besucher