9240 Electronic: AFC hat keine Funktion

      9240 Electronic: AFC hat keine Funktion

      Hallo zusammen,

      erstmal ein ganz großes Lob an das Forum. Cool, wie viele User diese tollen älteren Geräte zu schätzen wissen !!!

      Habe einen unverbastelten 9240 bekommen.

      Erstmal meine Frage: die AFC Schaltung arbeitet nicht.
      Bei Betätigung der Taste, leuchtet die LED, die FM Mitte wird nicht korrigiert.
      Ist der Sender nicht auf Mitte, wird durch AFC der Zeiger einen Millimeter weiter aus der Mitte gezogen. Sonst passiert nix.
      Hat evtl. jemand eine Idee dazu?

      Erste Bestandsaufnahme:
      Schwarzer Frontrahmen an Oberseite und Seiten total verkratzt.
      Gerät leuchtet nach einschalten :)
      Ton kommt auch :)
      Skalenzeiger bewegt sich und Sender werden empfangen. :)

      Auf dem zweiten Blick ist er schon etwas arbeitsaufwendiger.
      - Zahnrad an der Schwungscheibenachse gebrochen. Aber laut Forum gibt's ein Metall Ersatzzahnrad bei Völkner :thumbsup:

      - Ton auf einem Kanal verzerrt. Nach Erwärmung wird es schlimmer.
      Diesem Fehler bin ich schon nachgegangen. Ausgehend vom verzerrten Signal an der Endstufe, habe ich an jedem Modul den Ein- und Ausgang verfolgt.
      Am Ende war es ein TDA 1029 dessen Sockel gebrochen war und schlechten Kontakt hatte. Vorhin die 3 Sockel getauscht. Jetzt toller Klang :thumbsup:

      - Elkos im Netzteil habe ich bis auf den 3300 getauscht.

      - Kalte Lötstellen habe ich bis jetzt keine einzige gefunden.

      Was ich noch machen möchte:

      - Kondensatoren im Signalweg tauschen. Ich weiss noch nicht, ob ich komplett alle Elkos tauschen soll.
      - Trimmpotis in Endstufe + Treiber tauschen.
      - Tuner Frequenz auf 108 MHZ erweitern.
      - evtl. den Frontrahmen lackieren

      Bis denne, Vielen Dank für das tolle Forum und vielleicht hat jemand einen Tipp zum AFC ;)
      Hallo Mystic,

      Bei nicht funktionierender AFC besteht primär Verdacht auf defekten TCA 530.

      An Elkos im Signalweg sollten die kleinen (meist blauen axialen Philips) 1 µF im Stereodekoder und C2163 und C2164 auf der Hauptplatine durch 1µF Folienkondensatoren (bevorzugt im passenden Rastermass) ersetzt werden. Diese vier sind mittlerweile immer (!) sehr stark gealtert, trocken oder mit erhöhtem Leckstrom.

      Gruss,
      Reinhard
      Moin, moin,

      (bei mir IST gerade Morgen ...) -- die 1 uF Philips axial sind bei meinen Geraeten in der Tat eigentlich immer defekt gewesen. Wenn nicht, dann hatten sie deutlich mehr Kapazitaet, eher so 1,4 --- 1,7 uF. Ich bin daher, wie auch anderweitig schon beschrieben, generell dazu uebergegangen, diese kleinen Elkos durch Wima MKS 4 in 1,5 uF zu ersetzen, die naemlich im RM 15 mm erhaeltlich sind, und dann direkt passen.

      Ansonsten empfehle ich Achim's langen Thread zur Revision seines 9241 (die meisten Punkte sind beim 9240 gleich), und evtl. die Sammlung zur Revision von Modulen, wo sich einige interessante Punkte klaeren liessen. Insbesondere steht da eigentlich inzwischen so einiges dazu, welche Bauteile kritisch sind, und welche eher nicht. Bei der Inspektion auf jeden Fall genau nach Ringen um die Elkos schauen (ruhig auch mal einen rausnehmen und messen), weil Ringe immer ein Indiz fuer ausgelaufenen Elektrolyt sein koennen.

      Wenn der 3300 uF den Elko auf der NT-Platine bezeichnet, dann sollte der auch getauscht werden, denn er ist sonst immer als einer der ersten Elkos, die den Geist aufgeben. Siehe die diversen anderen Beitraege. Man kann hier ruhig auf 4700 uF gehen. Wichtig: Den "Heizwiderstand" darunter (6,8 kOhm) durch 33 kOhm oder 47 kOhm (1 W) ersetzen, und ebenso den zweiten von der Sorte unter der linken Endstufenplatine (von vorne betrachtet), denn der heizt nur einen der Entstufenelkos unnoetig auf.

      Besten Gruss,

      Michael
      Elkos sollte man niemals sinnlos beheizen, wenige Celsiusgrad Er(über)hitzung ergeben u.U. eine Lebensdauerverkürzung um eine Zehnerpotenz und mehr. Aus theoretisierten 2000 Betriebsstunden werden dann schnell 200, dabei könnte man auch auf 20.000 und mehr (heute sind mit modernen Elkos mehr als 200.000 MTBF* möglich) aufrüsten, wenn man bloß die sinnlose Fremdhitze ganz fernhalten würde.

      Welche Frage wohl noch offen geblieben ist in all den Threads bezüglich dieser Geräte ist die, ob diese "Heizwiderstände" wirklich so sinnlos sind wie sie scheinen, ob sie wirklich nur die Elkos entladen sollen, oder ob sie nicht eine Grundlast darstellen sollen, für die es mehrere Bewandnisse geben könnte. Grundlasten in Netzteilen helfen auch dabei sichere Betriebsverhältnisse herzustellen. Wenn dazu jemand der Mehrfachrestaurateure genau dieser Serien mehr hat, wäre es sicher für alle interessant.
      Ansonsten, wenn die Widerstände so niederohmig bleiben müßten, auf jeden Fall - Hitzeerzeuger weg! von den Elkos und hinein in einen gut belüfteten Kamin, wegbiegen oder lange Drähte dran oder umverlegen, was weiß ich was da platzmäßig geht, jedenfalls nicht durch die Leiterplatte hindurch die Elkos grillen.

      /
      *MTBF bedeutet nicht das zwingend jeder Elko dann ersetzt werden muß, das wäre ein dilletantischer Irrtum. Es bedeutet lediglich das zu dem Zeitpunkt die statistische Häufung als eine Kurve in ein Diagramm getragen zu diesem Zeitpunkt beginnt auf ein (noch lange lange nicht erreichtes) Maximum hin anzusteigen, sogenannte Spätausfallphase. Zuvor muß das Gerät und das Bauteil die viel gefährlichere Frühausfallphase,die innerhalb der Gewährleistungspflich verläuft überlebt haben. Für industrielle Entwicklungen ist dieser Wert statistisch interessant aber noch auf keinen Fall praktisch als Tauschzeitpunkt vorzusehen. Für kommerzielle und militärische Zwecke wird die Frühausfallrate übrigens durch "Einbrennen" auf nahe Null gedrückt und die Spätausfallphase durch einen erweiterten Temperaturbereich weiter nach hinten verlegt und das Bauteil in der Gerätefabrikation nicht sinnlos beheizt.
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Erstmal meine Frage: die AFC Schaltung arbeitet nicht.

      Bei Betätigung der Taste, leuchtet die LED, die FM Mitte wird nicht korrigiert.

      Ist der Sender nicht auf Mitte, wird durch AFC der Zeiger einen Millimeter weiter aus der Mitte gezogen. Sonst passiert nix.

      Hat evtl. jemand eine Idee dazu?
      Wenn die Mittenanzeige auf die Senderverstimmung reagiert, scheinen AFC-Ausgang des ZF-Moduls und
      der Differenzverstärker für das Drehspulinstrument in Ordnung zu sein.
      Bevor der TCA530 ersatzbeschafft wird, würde ich erst alles andere ausschließen, da selten und teuer.

      Vorschlag zur Fehlereingrenzung:

      -AFC aktivieren (LED muss leuchten)
      -Voltmeter an die beiden Anschlüsse von C2033 (0,68 µF) hängen
      -Abstimmung verändern. Bei Abweichung von der Sendermitte muss sich da zunehmend eine Spannung von bis zu ca. 0,2V aufbauen, in eine Richtung positiv, in die andere Richtung negativ.
      -Falls das in Ordnung ist, kommen die Widerstände R501, R502oder halt die Leiterbahnen, Kontaktpins und Lötpunkte bis hin zum TCA530, Pins 10 und 11 mit einer Unterbrechung in Frage. Erst wenn die Differenzspannung bis zu diesen beiden Pins durchkommt und sich trotzdem nichts beim Einschalten der AFC tut, ist es der TCA530.

      -Falls nicht, Eingang des IS2041 (Pin5) oder auch an Messpunkt C9 die Steuerspannung kontrollieren: AFC ein: 0 Volt, AFC aus: ca. 5,8V
      -Wenn das Steuersignal sauber kommt und der IC auch seine Betriebsspannung hat, können es das CMOS-IC, die Clampingdioden D2071, D2072 oder Kondensator C502 sein, die einen Kurzschluss verursachen.
      - Abstimmspannungsmodul ausbauen, Dioden mit Diodenprüffunktion Multimeter testen, In beide Richtungen muss sich die Flussspannung von 0,5-0,6V aufbauen, Kondensator auf Schluss prüfen. Sind es beide nicht, CMOS-IC tauschen.
      IC-Ersatz ist mit CMOS 4066 oder 4016 möglich, Funktion und Pin-Layout sind gleich.


      Viele Grüße,
      Christian
      **************************************************
      2 + 2 = 5 (für extrem große Werte von 2)
      Super Danke,

      IC's sind ok.
      Tuner ist nur verstellt.
      Hab den P516 im Abstimmspannungsmodul bewegt.
      nach rechts drehen, AFC funktioniert. nach links drehen, AFC funkt nicht.
      Steht jetzt ca. 1/4 Umdrehung vor Rechtsanschlag. So funkt. AFC.

      Mit dem Poti soll laut Abgleichanweisung der Sender un die 101 MHZ verschoben werden.
      Hat aber nur einen sehr geringen Einfluss. Drehung bewirkt eine Verschiebung von 100 - 100,5 Mhz.
      Das Poti für 87 Mhz reagiert heftiger.

      - habe jetzt Spg. vom Netzteil auf 45 V eingestellt. War ca. 46 V. Jetzt wird es auch mit dem P516 besser.
      Eingangsspannung am Abstimmungsmodul ist aber noch etwas zu hoch. 45.6 statt 45 Volt.

      Also, ich werde erstmal Kondensatoren tauschen, dann neu abgleichen und alles wird gut.
      Bin froh, dass keine IC's defekt sind. :thumbsup:
      Hallo Mystique,

      Da scheint aber schon was faul zu sein. Beim Verstellen von P516 müsste sich mehr tun, so 2-3 MHz Verstellbereich. Wie hoch ist die Versorgungsspannung am TCA530, Pin 5?. Wird denn die Abstimmspannung sauber geregelt?
      Beim Verdrehen von P516 müsste sich die Spannung an Pin 6 so zwischen 27 bis 33 Volt bewegen. Dabei darf sich die Spannung an Pin 8 nicht ändern.

      Gruss, Christian
      **************************************************
      2 + 2 = 5 (für extrem große Werte von 2)
      Moin,

      ein Nachtrag zu Jogi's Bemerkung: Damals hatte einer unserer Kollegen hier im Forum (Volker ?) gemessen, was mit diesen Widerstaenden erreicht wird. Solange Endstufen etc. angeklemmt waren, war der Effekt relativ gering, weil die Spannung auch ohne diese Widerstaende recht schnell runterfuhr beim Ausschalten.

      Anders ist das, wenn die Endstufen abgeklemmt sind -- dann fahren die Spannungen fuer die Endstufen, an denen ja sonst nichts dranhaengt, nicht runter. Dies ist dann unschoen, weil man +- 40 Volt anliegen hat, und dies zu unangenehmen Pannen fuer einen Reparateur fuehren kann, der nicht damit rechnet.

      Unser damaliges Fazit war, dass man nicht ganz darauf verzichten sollte, dass aber ein Herunterfahren auch nicht in 2 Sekunden passieren muss. Deshalb reichen 33 oder 47 kOhm auch aus. Die Grundlast im Betrieb kommt von den Endstufen selber, sofern sie richtig eingestelle sind (Ruhestrom).

      Ob sich die Entwickler noch mehr dabei gedacht haben, kann ich weder sagen noch erahnen. Ich kann nur berichten, dass ich diesen Tausch jetzt schon bei vielen Exemplaren (sicher mehr als 10) gemacht habe, und es mit den 33 kOhm oder 47 kOhm nie irgendwelche Probleme gab.

      Besten Gruss,

      Michael
      Danke Michael für die Gedächtnis-Auffrischung.
      Das reine Entladen soll nur eine praktische Zeitkonstante besitzen, da kommt es auf einige Minuten nicht an, ein paar Stunden wäre schon zu lange um noch dran zu denken das da Saft drauf war.
      Die von mir erwähnte Grundlast soll das Netzteil oder Teile davon generell niederzwingen, und das kontrolliert. Eine andere Bewandnis ist durch Belastung eine Funktion aufrecht zu erhalten, wie bei integrierten linearen Spannungsreglern, die ohne Grundlast unzuverlässig werden.
      Um ein praktisches Beispiel für den ersten Fall zu nennen muß man OPAMP-Netzteile die an die Spannungsgrenze der OPs gehen immer niederhalten, da sie auf keinen Fall bei Leerlauf mit der Spannung über die U-Grenz gehen dürfen.
      Solange das für diese Geräte nicht klipp wie Klärchen ist ist es ein gewisses Restrisiko, wenn man die Grundlast wegnimmt, die Widerstände hochohmiger macht. Grundlage des Ganzen ist die Vermutung das bei Firmen wie SABA Leute entwickelt haben, die wußten was sie taten. Vielleicht wollten sie aber auch nur das beim Ausschalten auch die Anzeigen schnell aus sind und nicht noch längere Zeit nachleuchteten - alles schon erlebt - dann täte es nichts die Widerstandswerte einfach heraufzusetzen, außer das diverse LEDs länger leuchten, wenn man das gerät ausschaltet.
      Gruß Jogi
      -------------
      Menschen mit Tiefgang laufen schneller auf Grund
      Nichts wird dem Menschen weniger verziehen, als Recht gehabt zu haben
      [frei nach W. Reus]
      Danke Euch :)

      hatte heut bissle Zeit um zu messen.
      Da stimmt irgendwas nicht so ganz.

      Chriss, ich habe mal Deine Messpunkte angeschaut.
      Erstmal Netzteil so eingestellt, dass am Abstimmungsmodul an Pin3 45 V anliegt.

      > Wie hoch ist die Versorgungsspannung am TCA530, Pin 5?.
      Pin 5 hat 40,7 V lt. Manual müssten es aber 36 V sein
      Pin 14 am TCA hat 40,6V laut Manual 24,5V ?
      hier ist dann definitiv was faul, doch TCA530 teildefekt?

      >Wird denn die Abstimmspannung sauber geregelt?
      Wie messe ich das am besten?

      Beim Verdrehen von P516 müsste sich die Spannung an Pin 6 so zwischen 27 bis 33 Volt bewegen.
      > bewegt sich 31,5 - 34 V

      > Dabei darf sich die Spannung an Pin 8 nicht ändern.
      Pin 8 ändert sich zwischen 23 und 20 V

      Nachdem habe ich die Widerstände, Trimmer und Kondensatoren im Abstimmungsmodul kontrolliert.
      Die sind alle in Ordnung. Kondensatoren und Trimmer habe ich auch mal gegen andere getauscht. Keine Änderung.
      C2061 und 2023 auf der Grundplatte einfach mal so kontrolliert. Die hatten 87uF statt 47uF. Habe die gleich getauscht.
      Auch keine Änderung.

      das hab ich auch kontrolliert:
      >AFC aktivieren (LED muss leuchten)
      >Voltmeter an die beiden Anschlüsse von C2033 (0,68 µF) hängen
      >Abstimmung verändern. Bei Abweichung von der Sendermitte muss sich da zunehmend eine Spannung von bis zu ca. 0,2V aufbauen, in eine >Richtung positiv, in die andere Richtung negativ.
      gemessen zwischen +- 0,45V


      >Falls nicht, Eingang des IS2041 (Pin5) oder auch an Messpunkt C9 die Steuerspannung kontrollieren: AFC ein: 0 Volt, AFC aus: ca. 5,8V
      ist OK 0 und 5,8 V

      >Wenn das Steuersignal sauber kommt und der IC auch seine Betriebsspannung hat, können es das CMOS-IC, die Clampingdioden D2071, D2072 oder >Kondensator C502 sein, die einen Kurzschluss verursachen.
      >Abstimmspannungsmodul ausbauen, Dioden mit Diodenprüffunktion Multimeter testen, In beide Richtungen muss sich die Flussspannung von >0,5-0,6V aufbauen, Kondensator auf Schluss prüfen
      ist auch ok
      Hallo Mystic,

      es ist wohl doch der TCA530 defekt.
      Deine Messergebnisse zeigen, dass die Regelung der Abstimmspannung nicht mehr arbeitet. Pin 6 ist ja der Ausgang, an dem die stabilisierte Spannung bereitgestellt wird. Über das Widerstandsnetzwerk um P516 wird ein darüber festgelegter Teilbetrag dieser Spannung an Pin 8 zurückgeliefert und mit der internen Referenzspannung verglichen. Ist die rückgelieferte Spannung zu hoch, senkt das IC die Ausgangsspannung, ist sie zu niedrig, wird sie erhöht, bis der Spannungsanteil wieder gleich der Referenzspannung ist.

      Mit P516 ist der genaue Spannungsanteil, der an Pin 8 zurückgeliefert wird, in gewissen Grenzen einstellbar. Wenn man nun an diesem Poti dreht, reagiert ein funktionierender TCA530 mit einer Änderung der Ausgangsspannung und stellt damit immer wieder die rückgelieferte Spannung auf seine interne Referenzspannung nach - Prinzip nichtinvertierende Opamp-Verstärkerschaltung.

      Neben der Rückkoppelung über das Widerstandsnetzwerk geht in die Regelung der Ausgangsspannung auch die Differenzspannung an den AFC-Eingängen mit ein. Da die Regelung bei dir nun aber nicht funktioniert, spinnt auch das AFC.

      Bleibt wohl nur, den TCA530 zu ersetzen. Aber Vorsicht, in der Bucht gibts von den Chinesen nur Fakes, such mal hier im Forum nach leidvollen Erfahrungen damit. Besser fährst du sicher mit einer Anfrage hier im Forum ggf. auch direkt beim Mitglied "Tommy". Er hat einige Ersatzteile für diese Receiver anzubieten.
      Eine zweite Möglichkeit ist der Nachbau dieser Spannungsstabilisierung, den Thread dazu hast du sicher schon entdeckt.

      Viel Erfolg wünscht dir Christian.
      **************************************************
      2 + 2 = 5 (für extrem große Werte von 2)
      Hi Jogi,

      auch wenn das jetzt ein wenig vom anderen Problem abweicht, noch ein paar Ergaenzungen:

      - die beiden Endstufen haben getrennte Spannungen. ICs sind keine verbaut, nur die Treiber haengen noch mit dran. Schon die alleine ziehen die Spannung langsam runter nach dem Ausschalten. Eine Notwendigkeit fuer eine zus. Grundlast kann ich wirklich nicht erkennen -- ausser eben den Fall, dass die Treiber gezogen sind und die Endtufen abgeloetet. Dann wuerden die ca. 40 V stehen bleiben, was man nicht gerne moechte. Da diese aber nicht rasch runterfahren muessen, reichen dann die genannten 33 ... 47 kOhm locker aus.

      - ich gehe immer davon aus, dass die Ingenieure sich bei den Loesungen etwas gedacht haben, aber ich gehe (inzischen) nicht mehr davon aus, dass die Schaltungen optimal oder fehlerfrei sind. Das sind sie ganz sicher nicht, denn wir wissen inzwischen einige Details (die ja hier auch gut diskutiert worden sind) und kennen das generelle Problem, dass viele Teile (z.B. einige Module) fuer mehrere Geraete passen mussten. Das setzt Randbedingungen, die eine optimale Loesung unmoeglich machen, egal, wie gut der Ingenieur war.

      - ein konkretes Beispiel ist etwa die Massefuehrung in den grossen Saba-Receivern. Die ist einfach nicht wirklich gelungen, wie man am Brummproblem (KH-Ausgang) hoert. Rolf und Peter (?) hatten damals hier im Forum einige Vorschlaege fuer Aenderungen gemacht, die das Problem _deutlich_ reduzieren. Das ist also ein Punkt, der klar zeigt, dass hier nicht vom perfekten Aufschlag ausgegangen werden sollte.

      - ganz nebenbei wissen wir doch auch, dass immer wirtschaftliche Randbedingungen zu weiteren Nebenbedinungen in Entwicklung und Fertigung gefuehrt haben, die so manche gute Loesung auf dem Entwurfsbrett spaeter verwaessert haben. Das war bei Saba ganz sicher der Fall, man sieht das an vielen Stellen.


      So, nun noch eine Anmerkung zum vorletzten Beitrag: Wenn Elkos 80 statt 47 uF haben, so liegt bei diesen Geraeten meist KEIN Fehler vor. Wenn das z.B. ein roter Roederstein war, der ansonsten aber keine Risse zeigt, so ist er sehr wahrscheinlich noch tip top in Ordnung. Ebenso bei diversen anderen Fabrikaten (wie Rubycon etc). Tatsaechlich ist es genau diese Beobachtung (die ich auch oft mache), die mich bei den Revisionen dieser Geraete dazu bringt, beim Ersatz (wenn noetig) eher etwas grosszuegig mit der Kapazitaet zu sein. Das ist in diversen anderen Threads recht ausfuehrlich diskutiert.

      Ganz konkret: Es gibt viele Elkos mit 47 uF als Stuetzelkos auf den Modulen. Wenn die kranken, ersetzt ich sie nicht durch 47 uF, sondern durch 68 uF (habe mal einen guenstigen Restposten im Beutel erstanden fuer diesen Zweck). Das ist dann recht nahe am "Mittel", und somit (aus meiner Sicht) voellig gerechtfertigt -- auch wenn da jetzt eine andere Zahl draufsteht. Daher ist auch 4700 uF statt 3300 uF fuer den einen Elko auf der NT-Karte problemlos.

      Besten Gruss,

      Michael