Angepinnt Digitalanzeige, RDS etc. beim 9241 und 9260

      Ich habe bestimmt 30x versucht, das "D" Segment K1 zum aufleuchten zu bringen...die anderen drei leuchten bei der kleinsten Berührung, K1 jedoch nicht, egal, wie sehr ich den Kontakt mit der Messspitze "bearbeite"...
      Ich werde jedoch später den Test mit dem von Dir angesprochenen Segment machen...
      Ich habe jetzt einige Segmente durchprobiert, auch das von Dir beschriebene - bis hin zum "-" im linken Block - das System ist ja nicht schwer zu verstehen...
      Alle LED bekomme ich zum leuchten - außer Segment "D" im Block K1

      Kann man die betreffende LED austauschen, oder ist das gesamte Digital - Element damit hinfällig...?
      Hallo Carsten,

      das ist ja nicht so schön....es bedeutet, dass die LED von Segment "D" in diesem Ziffernblock (k1) defekt ist, schade!
      Wenn Du den AY-5-8100 austauschst, werden voraussichtlich alle Ziffern wieder arbeiten, nur bei der ganz rechten wird weiterhin das untere waagerechte Segment fehlen, Davon betroffen sind nur nicht die Ziffern 1, 4, 7 und 9. Bei UKW ist die letzte Ziffer aber immer 0 oder 5, da sieht man es also immer.

      Es gibt jetzt folgende Optionen:
      • Bei Tommy (Kettronic) ein Displaymodul (das LED-Anzeigteil) oder ggf. komplette Displayplatte für den 9241 nachfragen (ggf. im Austausch). Das wäre für Dich die günstigste Lösung.
      • Das eigentliche Display ausbauen/auslöten und jemandem schicken, der das Display gemäss der Beschreibung von Volker ("Vorex") reparieren kann 9241 Digitalanzeigensegmentreparatur mit SMD-LED . Es ist die betroffene Micro-LED auszutauschen und die neue in ihrer Helligkeit an die übrigen anzupassen Ich habe diese Anpassung immer mit Schwärzung der neuen LED mit schwarzem Filzschreiber gemacht, damit hinterher gleiche Segmenthelligkeit gegeben ist (heutige LED leuchten wesentlich heller als in 1980). Der komplette Austausch aller LED ist dann nicht nötig (eine grausame Arbeit). Für den Ausbau des Diplays muss die gesamte grössere Platine, auf der das Display sitzt erst ausgebaut werden und auf dessen Rückseite die komplette aufgesetzte Displayplatte ausgelötet werden (an den 16 PINs, diese müssen in der kleineren Displayplatte, an den Lötstellen, wo Du zuletzt gemessen hast, aber dranbleiben ). Die Display-Reparatur ist anspruchsvoll (kein Vergleich mit den bisherigen einfachen Arbeiten) wegen der winzigen LEDs - aber für Geübte machbar (ich habe es zweimal gemacht, beide male waren erfolgreich).
      • Den ganzen Receiver verschicken, der Reparateur des Displays baut es dann selbst korrekt aus und wieder ein (zusätzliche Option: Er kann bei Wunsch auch nach anderen verschlissenen Teilen im Receiver sehen und diese gleich mit ersetzen)
      • Sich mit dem einen noch fehlerhaften Segment in der rechten Ziffer abfinden nachdem das IC ersetzt ist.


      Ein original Ersatz LED-Display, oder eins dass statt des verbauten in den 9241 einsetzbar ist, gibt es nicht mehr.
      Den gesamten Zähler samt Display zu ersetzen, ist eine andere Möglichkeit, aber meist nicht gleichwertig (Ausnahme: Kliem-Zähler) zum original Saba Display oder kostenintensiv.

      a) eBay-Artikelnummer: 283221118143
      Dieses Display hat nur eine Nachkommastelle für FM. Exakter Abgleich bei UKW beim 9241 benötigt aber zwei Nachkommastellen.

      b) PLJ-6LED-H LED Display Digital Signal Frequency Counter Cymometer 1MHz-1000MHz (eBay-Artikelnummer: 223473992333)
      Da habe ich schlechte Erfahrung: Mehrfach habe ich dieses Teil bestellt, aber statt des Typs "H" jedes mal einen anderen Typ (A) bekommen, der nur für nominal bis 60MHz ausgelegt ist und damit ungeeignet. Es muss der Typ H sein (1000 MHz), damit er bei 119MHz (UKW+ZF) noch ausreichende Empfindlichkeit hat. Die chinesischen Händler kennen diesen wesentlichen technischen Unterschied aber zumeist nicht und auf die Beschreibungen im Angebot kann man sich nach meiner Erfahrung leider nicht verlassen. Beide Versionen sehen ähnlich aus, auch wenn es auf der Rückseite markante Bestückungsunterschiede gibt. Ausserdem ist diese Anzeige sowieso für MW nicht brauchbar. Wenn man auf MW-Anzeige verzichtet und tatsächlich den H-Typ bekommt, ist es eine Lösung. Die 8-stellige Anzeige PLJ-8LED-H, die man bis 1000 MHz leicht bekommen kann, passt geometrisch und von der Ziffernzahl her nicht. Der Einbau erfordert Fachkenntnisse.

      c) Umbau der SABA LED Anzeige auf 7-Segment LED-Einzelbausteine, wie anfangs bei diesem Thema hier von mir beschrieben. Zeitaufwendige Arbeit. Erfordert Kenntnisse zur 7-Segment-Anzeige mit common cathode und Adaptierung der Verdrahtung für die verbauten LED Bausteine mit korrekter Matrixansteuerung. (Digitalanzeige, RDS etc. beim 9241 und 9260 )

      d) Frequenzzählermodul RFZ 5 für UKW/MW von H. Kliem. Lieferbarkeit müsste erfragt werden. (haraldkliem.jimdofree.com/elektronikprojekte/rfz-5-ukw-mw/ ). Der Einbau erfordert Fachkenntnisse.




      Zur Illustration, wie winzig die eigentlichen LEDs im Display sind, die sich unter einer Schlitzmaske befinden:



      Die Leiterbahn ist weniger als 1mm breit, die LED also kleiner als 1mm x 1mm. Die Verdrahtung ist "freitragend" durch den Raum mit haardünnen Drähtchen, die kaum sichtbar sind. Berührung der Bestückungsseite birgt bereits das Risiko der Zerstörung dieser nahezu unsichtbaren freien Kontaktierungen (wire bonds).
      saba-forum.dl2jas.com/bildupload/Vorex_20120325_10.jpg

      Die defekte LED auf der Kathodenleiterbahn wird samt seines Drahtanschlusses zur Anode entfernt und an dessen Stelle eine kleine rote SMD-LED der Bauform 0603 (1,6mm x 0,8mm) polaritätsrichtig und von dessen Orientierung so eingelötet, so dass sie in die Öffnung der Schlitzmaske passt.

      Die Position der defekten LED im rechten Zifferblock, Segment "D" im Displaybaustein ist mit einem Pfeil markiert:




      Wenn Du an eine Reparatur des Displays denkst,....ich könnte es...., nur falls Du von Tommy kein funktionsfähiges Displaymodul bekommen kannst.

      Gruß
      Reinhard

      [list][/list]

      Dieser Beitrag wurde bereits 12 mal editiert, zuletzt von „oldiefan“ ()

      Hallo Reinhard,

      bei Tommy bekomme ich weder das IC noch das Displaymodul. Ich werde es wegen des IC's jetzt in England versuchen...
      Wie stellst Du Dir das mit der Reparatur des Displays vor? Was müsste ich tun...? Display "ausbauen" und zu Dir senden...?

      LG Carsten

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „WBC“ ()

      Hallo Carsten,

      ich sehe diese beiden Optionen
      a) ganzen Receiver senden zusammen mit dem neuen IC, nachdem Du es bekommen hast. Ich baue nach der Displayreparatur alles zusammen und Du bekommst den Receiver in deiner Verpackung zurück. Bringen ist eine Option, wenn dein Weg nach Freiburg/Breisgau nicht zu lang wäre;
      b) Du baust das Anzeigemodul aus und sendest es mir mit dem darauf befindlichen Displaymodul. Dafür sind am Anzeigemodul recht viele Leitungen ab- und hinterher von Dir wieder anzulöten. Vorher Fotos von den angelöteten Leitungen an den Lötstellen machen, so dass es hinterher beim Anlöten keine Verwechselungen oder Fragezeichen gibt.

      Dass Du vom sowieso ausgebauten Anzeigemodul auch noch das Displaymodul auslötest und mir nur das schickst, darin sehe ich für Dich und mich keinen Vorteil.

      Pro a)
      Sollte noch irgendetwas sein, was bei der Ferndiagnose übersehen wurde, könnte ich das sehen und korrigieren , wenn der Receiver vor mir steht
      Kein Risiko /Umstände für den Einbau / Testen für Dich

      Contra a)
      Versandrisiko (nach meiner Erfahrung verschwindend gering bei sorgfältiger Verpackung, dick und fest nach allen Seiten gepolstert, keine Styroporflocken oder nur lose Zeitungskneuel).
      - entfällt bei Vorbeibringen (Freiburg, wenn möglich)
      Versandkosten: Hermes 22,-€ für 2 Versandwege (hin- und rück-). DHL ca 35,- €.

      Pro b)
      einfacherer Versand in kleinem Paket (kein Päckchen, da bei Päckchenverlust keine Haftung des Paketdienstleisters)
      Versandkosten ca. 9-11 € (Hermes bzw. DHL für hin- und rück-)

      Contra b)
      Lötaufwand/Wiederanschluss der Leitungen und Prüfung und Zusammenbau des Receivers (einschl. Zählerbox) d.h. Aufwand für Dich.

      Gruß
      Reinhard
      Hi Carsten,

      wenn Reinhard Dir das anbietet, würde ich Dir dazu raten, das Gerät irgendwie zu ihm zu schaffen. Erstens ist danach Ruhe, und alles perfekt im Lot, und zweitens werden wir in Thread noch lernen, was alles im Argen lag. Das ist dann auch für zukünftige Fälle von Interesse, denn viele dieser Fehler treten ja immer mal wieder auf.

      Besten Gruss,

      Michael

      Nachteule schrieb:

      Das hier fürt zu nix. Da muss Einer her der das machen kann.


      ...das meinte ich, Reinhard hat sich angeboten das Gerät an sich zu nehmen und es reparieren und eine komplette Durchsicht zu machen ; wollte halt keinen Namen nennen.
      Ich hoffe es war keiner stinkig auf mich :rolleyes: .

      Und wegen der Bilder von Carsten : meinte ich auch NUR !
      Er ist öfterst freundlich aufgefordert worden die betrefflichen stellen abzulichten und hier hochzuladen. Was kam,... nix. :whistling:
      Auch mit den Lötkolben mit 100 Watt. Junge,... im Gerät sind MOS IC zuhause. Da kannst nicht mit so einen Dachrinnen_ Lötkolben "arbeiten "
      Da brauchst eine regelbare ESD Lötstation,feiner Lötspitze,... mit allem was dazu gehört; Matte, Armbandverbindung ! KEINE Erdung mit der Hausinstalation !

      Nochmals sorry :huh:
      Grüße <3 Mia <3

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Nachteule“ ()

      Hallo Mia,

      tja, das ist immer so 'ne Sache mit den Fakten.

      Der "100 W" Lötkolben hat definitiv genau deren 16...und die geforderten Pics habe ist - nachdem ich das mit dem Kleinermachen und Hochladen endlich gerafft hatte - versucht, immer sofort einzustellen... bitte hier doch an die Tatsachen halten, Danke... ;)

      Inwieweit sich für mich eine Lötstation lohnt...? - ich denke eher nicht...- bisher bin ich mit meinem 16Watt-Gerät immer gut klargekommen, auch wenn es hier grenzwertig war, das gebe ich zu...
      Eigentlich bin ich auch nicht der Typ, der sich dazu herausfordern lässt, sich erklären zu müssen. Deshalb auch an dieser Stelle finito... ;)

      Und..."Junge" - naja...aber gut - ich bin neu hier...

      Carsten
      Hallo Mia,

      Carsten hat bisher alles ordentlich hinbekommen, wenn es dafür anfangs mal einen 2. Anlauf braucht, ist es ja auch kein Drama.
      Nicht die Latte so hoch legen. Wer in allem bereits perfekt ist, braucht ja keine Hilfe. Aber es geht doch hier um Hilfestellung und Erklärung.

      Gruß
      Reinhard

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „oldiefan“ ()

      oldiefan schrieb:


      ... Wer in allem bereits perfekt ist, braucht ja keine Hilfe. Aber es geht doch hier um Hilfestellung und Erklärung.


      Ja genau, danke! Nicht nur der Hilfesuchende, sondern auch die Mitleser (ich) können noch was lernen!


      Noch ein Hinweis zum Versand:
      Leider mußte ich erst letzten Herbst selbst wieder die schmerzliche Erfahrung machen. Trotz sorgfältiger Verpackung, Styropor, Blisterfolie, Zeitung und dicker Karton hatte mir DHL einen Receiver beim Versand zerstört. Das Paket lag dann mehrere Wochen im Paketzentrum, ehe es umgepackt ausgeliefert wurde. Es sah so aus, als sei ein Gabelstapler in das Paket gefahren. Seither kämpfe ich immer noch um die Erstattung des Schadens! Dabei ist der ideelle Schaden viel höher als finanzielle. Durch den Versand bekommen die Grundplatinen auch gerne mal Haarrisse.
      Kurzum, wenn möglich, Versand vermeiden und selber transportieren!

      Gruß
      Wolfgang
      geht nicht - gibt's nicht!
      Hallo all,
      nochmal eine Grundsatzfrage zum Thema, welche mir bereits seitdem ich mit der Revision des 9241 begonnen habe, im Kopf rumspukt.

      Gibt es eine Möglichkeit, den Receiver auf 240V umzustellen? Bei einem meiner Plattenspieler konnte ich das durch das Umlöten des Trafos (Wicklungsabgriff) bewerkstelligen. Ich befürchte, hier ist das nicht möglich... korrekt...?
      Ich denke, bei ca.243V tatsächlicher Netzspannung sind das ca.10% "Überlast". Das dürfte für die alten Bauteile gehörigen thermischen Stress bedeuten...

      Wie sind eure Meinungen dazu...?

      LG Carsten
      Hi Carsten,

      wie Du richtig vermutest, geht das hier nicht, weil die Trafos keinen anderen Abgriff haben. Wir haben an anderer Stelle diverse kleine Massnahmen diskutiert, wie man die Waermeentwicklung reduzieren kann. Aber insgesamt ist bei den 92xx kein Grund zur Sorge, die stecken das recht gut weg ...

      Besten Gruss,

      Michael

      kugel-balu schrieb:

      bei den 92xx kein Grund zur Sorge, die stecken das recht gut weg ...


      dem stimme ich voll zu.
      Aber es gibt eine Bedingung: Der obere Deckel muss freibleiben. Da dürfen keine Bücher abgelegt werden oder Zeitungen oder....und der Abstand zu einem Regalbrett darüber oder was auch immer muss wenigstens 10cm betragen.

      Ich habe schon 9241 gesehen (die werden allerdings wärmer als 9260 wegen der besonderen Zählerbox im 9241), die gefühlt ein Dutzend ernste Defekte gleichzeitig hatten (multimorbide) und das wegen unzureichnder Belüftung. Das hatte nichts mit der Netzspannung zu tun.

      Thermisch bedingte Schäden können z.B. sein:
      • beschleunigtes / verfrühtes Auseinanderfallen der Trimmpotentiometer, dadurch ggf. auch Endstufenschaden
      • beschleunigte /verfrühte Defekte der MOS-Schalter
      • beschleunigter /verfrühter Ausfall der Kleinelkos durch Austrocknung, dadurch auch Kanalungleichheiten, Hochtonverlust und Kanalausfall
      • beschleunigter /verfrühter Beleuchtungsausfall
      • verfrühter Ausfall des TCA530 (der wird sowieso schon intern zwangsbeheizt, eine Umgebungstemperatur von zusätzlich 50°C ist ihm aber trotzdem nicht zuträglich)
      • Netzteilfehler, usw.
      Gruß
      Reinhard
      Hallo in die Runde. Meine 5 cent:

      Reinhards Angebot ist sehr großzügig. Ich würde trotzdem einen anderen Vorschlag machen, der bei mir in solchen Fällen fast immer zum Ziel geführt hat: Geduld haben! Bis auf die paar Segmente ist dein Gerät in Ordnung. Bau es zusammen, erfreue dich daran und warte, bis ein Displaymodul auftaucht. Bedenke, wie häufig das Gerät ist. Da wird immer mal eins geschlachtet, ob von einem Forianer hier oder die Brocken tauchen auf ebay auf, oder wo auch immer. Dann kannst du es immer noch tauschen.

      Zum Thema Wärme:
      Mein 9241, Alltagsgerät im Wohnzimmer, muss seit 1993 mit einem Regalfach vorlieb nehmen mit zwei Fingerbreit Luft oberhalb. Klar wird er sehr warm. Er läuft fast jeden Tag, meist mehrere Stunden. Ausfälle seitdem: keine. Und er hängt an der heutigen Netzspannung, weil ich für folgende Maßnahme zu faul bin:

      An dieser Stelle nochmal - obwohl schon oft gebracht - die kleine Maßnahme zur Verringerung der Netzspannung:
      Ein Stino-Trafo 230 Volt auf 15 Volt. Größenordnung 1 A sekundär. Der Trafo wird als Autotrafo geschaltet: Eingang 230V-Wicklung, Ausgang dito plus die Sekundärwicklung in Reihe. Bei 235 Volt Netzspannung ergibt das je nach Polung der Sekundärwicklung am Ausgang entweder 250 V (235 + 15, braucht man nicht) oder eben 220 Volt (235 - 15V). So geschaltet baust du das Ding in ein kleines Gehäuse (ausgedientes Computernetzteilgehäuse o.ä.) und fertig ist die Laube bzw. deine 220 Volt Netzspannung. Der Trafo muss nur die Leistung verarbeiten, die dem Sekundärstrom mal der Spannungsdifferenz 15 Volt entspricht. Der wird also mit einem 9241 als Last maximal handwarm.

      VG Stefan
    • Benutzer online 4

      4 Besucher